Carlos Brando

Nome do Jogo

SQLite3-Ruby 1.2.4

Jamis Buck acabou de anunciar o lançamento da versão 1.2.3 do gem SQLite3-Ruby.

Entre as novidades está uma correção nas permissões dos arquivos database.rb e translator.rb, que na versão 1.2.2 estavam incorretas, o que acarretava em impedir a instalação em sistemas *nix. Também foram incluídas melhorias no código para aumentar a compatibilidade com o futuro Ruby 1.9, além de melhorias na performance.

Os leitores mais atentos devem ter notado a diferença no número da versão no título deste artigo e na primeira linha do texto. Isto se dá, porque minutos depois do anúncio de Jamis, ao atualizar a versão na minha máquina foi instalada a versão 1.2.4, possivelmente alguma coisa deu errado e um patch emergencial foi necessário.

Para atualizar ou instalar:

gem install sqlite3-ruby

Comments